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アプリケーションをWinActorで開こうとしても正常に動作しないときの対処法を教えてください。

Q:WinActorでアプリケーションを開こうとしても正常に動作しないときの対処法を教えてください。
本記事では、アプリケーション起動時のエラーの解決方法を説明いたします。

エラーの確認方法


「アクション\コマンド実行」ノードからアプリケーション(拡張子が.exe・.batファイル)を実行すると、上記の表示が出てアプリケーションが実行されないことがあります。

「13_ファイル関連\02_ファイル操作\コマンド実行」ノードからアプリケーションを実行すると、上記の表示が出てアプリケーションが実行されないことがあります。

「13_ファイル関連\02_ファイル操作\Explorerでファイル開く」ノードからアプリケーションを実行すると、上記の表示が出てアプリケーションが実行されないことがあります。

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原因

当該エラーは指定したファイルパスが誤っていたり、ファイルが移動して指定したディレクトリに存在しなかったりする場合に発生します。

しかしファイルパスを確認すると、見かけ上は誤りがない場合があります。
その場合はファイルパスの取得方法に問題がある場合があります。
エラーが発生するファイルパスの取得方法を説明いたします。

手順1


対象ファイルを右クリックし「プロパティ」を選択します。

手順2


「セキュリティ」タブを選択し、オブジェクト名を右から左へ選択してコピーします。

結果

取得した文字列をWinActor本体の入力欄、サクラエディタ、秀丸エディタ、Wordなど(メモ帳は無理です)に貼り付けると、文字先頭の前に見えない一文字があることが確認できます。
確認方法の一例として、カーソルを左端に合わせてから右キーを一回押してもカーソルが移動しません。

この見えない一文字は双方向テキストの記号です。
記号の内容の細かな説明は省略いたしますが、これが含まれているためにファイルパスが正しく認識されません。

対処法

双方向テキストの記号を消す


カーソルを一番左まで移動させ、Deleteボタンを押下すると双方向テキストの記号が消えます。

ファイルパスの取得方法を変える


Shiftキーを押しながら対象ファイルを右クリックすると「パスのコピー」という選択肢が表示されるためそれをクリックします。
Windows11であれば右クリックするだけで「パスのコピー」の選択肢があります。
またファイルを選択した状態で「Ctrl+Shift+C」キーを押してもパスが取得できます。

貼り付けると両端にダブルクォーテーション「”」が付いているため消去します。
この手順では双方向テキストの記号は入りません。

手打ちする(非推奨)

WinActorの入力欄に直接手打ちする場合、双方向テキストの記号を入れることは不可能です。
しかし手間がかかる上に誤字の原因となるため非推奨です。